Vai al contenuto
najaru

(IT10) The second post is Adsense

Recommended Posts

najaru

VEDI FILE IN ALLEGATO.

second_adsense.jpg

<br />

<br />

<br />

Per scaricare il file devi essere un Advanced Member (esegui la sottoscrizione)

<br />

To download the file you have to subscribe to Advanced Member

<br />

<br />

<br />

<div style="margin: 0 auto 0 auto; width: 700px;"><h2 class="maintitle">Sottoscrivi il passaggio ad Advanced Member - Subscribe to Advance Member</h2><table class="ipb_table"><tr><td class='row2' style="width: 65%;" align='center'>Costo: 4Euro/12mesi</td><td class='row2' style="width: 65%;" align='center'><a href="http://www.invisionita.it/forum/index.php?app=subscriptions"><span class="input_submit">Subscribe now!</span></a></td></tr></table></div>

IT10SecondPostIsAdsense.zip

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Salve

Ho provato ad installare questo mod di cui ho assolutamente bisogno ma ho un problema:

			<if test="initIgnoredPost:|:$post['post']['_repignored'] == 1 || $post['post']['_ignored']">
<script type='text/javascript'>
ipb.topic.setPostHidden( {$post['post']['pid']} );
$('unhide_post_{$post['post']['pid']}').show();
</script>
</if>

Questa stringa non esiste in topicViewTemplate del mio skin. Cosa si fa?? ho pagato per advanced member apposta per questo mod, non ditemi che non funziona su 3.0.5 :D

Aiuto sarebbe moooolto gradito, grazieee!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

certo che funziona.

in caso di problemi ti rimborsiamo ci mancherebbe, non ci mettiamo mica a fare casini per pochi euro :D

probabilmente usi una skin diversa dallo standard.

puoi dirmi che skin usi (sperando che sia free, cosi la monto e lo provo subito) oppure potresti postare tutto il codice del topicviewtemplate? oppure mi mandi in privato la skin e faccio i test dovuti in modo da avere la sicurezza che vada....

mia mail fo.andrea chiocciola gmail.com

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

oppure prova a metterlo dopo questo


<if test="reportedPostData:|:$this->memberData['_cache']['report_temp']['post_marker']['post'][ $post['post']['pid'] ]['gfx'] > 0">
<ul id='post-report-{$post['post']['pid']}_menucontent' class='ipbmenu_content report_menu'>
<li><a href="{parse url="app=core&module=reports&do=show_report&rid={$this->memberData['_cache']['report_temp']['post_marker']['post'][ $post['post']['pid'] ]['info']['id']}" base="public"}" id='report_mark_{$post['post']['pid']}'><img src='{$this->settings['img_url']}/reports/mark_complete.png' alt='' /> {$this->lang->words['report_menu_mark_complete']}</a></li>
<li><a href="{$this->settings['base_url']}app=core&module=reports&section=reports&do=show_report&rid={$this->memberData['_cache']['report_temp']['post_marker']['post'][$post['post']['pid']]['info']['id']}"><img src='{$this->settings['img_url']}/reports/view_report.png' alt='' /> {$this->lang->words['report_menu_view_report']}</a></li>
</ul>
<script type="text/javascript">
$('report_mark_{$post['post']['pid']}').observe('click',
ipb.global.updateReportStatus.bindAsEventListener(
this, {$this->memberData['_cache']['report_temp']['post_marker']['post'][$post['post']['pid']]['info']['id']},2,2
)
);
</script>
</if>
</div>
<!-- </if> -->
</div>

mi raccomando prima di pasticciare fatti un backup o della skin o del codice originale del topicviewtemplate :D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Allora....il tuo codice ha dei bug e devi fare le giuste correzioni. Sono semplici mancanze ma per chi non se ne intende di php e codici queste pochezze possono diventare veri e propri intoppi :P (chi non se ne intende = io lol)

Dunque nel file allegato esattamente come ho postato prima dici di cercare la stringa

			<if test="initIgnoredPost:|:$post['post']['_repignored'] == 1 || $post['post']['_ignored']">
<script type='text/javascript'>
ipb.topic.setPostHidden( {$post['post']['pid']} );
$('unhide_post_{$post['post']['pid']}').show();
</script>
</if>

La stringa esiste ma siccome non sei stato attento quando l'hai inserita, nota che:

			<if test="initIgnoredPost:|:$post['post']['_repignored'] == 1 || $post['post']['_ignored']">

non si trova allineato con :

			</script>
</if>

quindi il mio editor di php non riusciva a trovarmelo ecco perche' mi dava stringa inesistente. :D

Mi e' bastato eliminare lo spazio in piu' e si e' risolto tutto.

Stessa cosa con il codice da inserire...non e' allineato e mi causava errori nella pagina.

Questo per quanto riguarda i codici. Un'altra cosa che dovresti corregere e' il piccolo file immagine; non tutti i host permettono il link esterno delle immagini, quindi io ho dovuto creare una mia immagine ed andare a cercare la cartella giusta da inserire e poi linkare nel codice. Specifica per i noob come me che devono inserire immagine, dove e come linkarla :P

In fine, ho visto che voi questo mod non ce l'avete ma a me serve quindi non so come ovviare al problema: dunque io ho installato i mod Hide content di terrabyte e Thanks di elad nava, e il tuo codice nel template mi si va ad inserire subito dopo il primo post ma prima dell'elenco delle persone che hanno premuto il pulsante thanks e quindi mi compare come se l'adsense facesse parte del primo post e non mi piace perche' mi sfasa lo skin.

Un bel po' di cose da corregere insomma. A me piace questa mod ma vorrei sapere come fare per postarla dietro i ringraziatori e non prima. Spero di essermi spiegata bene :D

Grazie per la risposta di prima ma ero intenta a maneggiare il php editor e non l'avevo letto rofl...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

1- le modifiche codice se fatte sono intese direttamente nel codice acp, e non su programmi particolari, quindi mi spiace se hai avuto problemi, ma gli allineamenti non mi hanno mai creato problemi se non di lettura.

2- mi sembra molto strano che non si possa richiamare un immagine esterna..... comunque è ovvio che quell'immagine si può sostituire con qualsiasi altra presente nel tuo dominio

3- se tu hai altree mod installate è ovvio che devi adattarla..... se vuoi posso vedere, ma io non ho il thanks quindi devi darmi tu la possibilità di provare (non posso avere tutte le mod a pagamento possibili....). Comunque penso proprio che se ti ricordi il codice che hai aggiunto dei thank (magari cè anche il commento) dovresti semplicemente metterla dopo.... :P

ripeto se mi metti tutto il codice lo confronto.....

oppure prova a metterlo subito prima di:


<hr />
<if test="endFirstPost:|:$post['post']['_end_first_post']">
<!-- END OF FIRST POST IN LINEAR+, SHOW BUTTONS AND NEW TITLE -->
<br />
<div class='topic_controls'>
{$topic['SHOW_PAGES']}
<ul class='topic_buttons'>
<if test="bottomNewTopic:|:$forum['_user_can_post']">
<li><a href='{parse url="module=post&section=post&do=new_post&f={$forum['id']}" base="publicWithApp"}' title='{$this->lang->words['start_new_topic']}' accesskey='n'>{parse replacement="topic_icon"} {$this->lang->words['start_new_topic']}</a></li>
<else />
<li class='disabled'><span>{$this->lang->words['top_cannot_start']}</span></li>
</if>
<if test="bottomIsClosed:|:$displayData['reply_button']['image'] == 'locked'">

comunque considera che non avevo ancora avuto molti feedback, quindi è normale che ci possano essere piccoli aggiustamenti da fare :D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

prendi i miei commenti in modo costruttivo, eh ...non essere permaloso :P

Sto provando a postare il codice in varie sezioni della pagina....le modifiche apportate con i mod hide e thanks hanno influito in modo pesante sul codice del file. Non e' facile capire dove si potrebbe inserire visto che si estendono fino a fine pagina (mi riferisco alla visualizzazione codici...insomma porta pazienza, come ho scritto prima non sono esperta...magari lo fossi! :P )

In che riguarda l'editare del codice, ho sempre fatto le modifiche usando l'editor, cercare a vista diventa pesante per me; apro semplicemente il file nel editor e clicco il piccolo pulsante find. Fino a te non ho riscontrato il problema di stringa assente per colpa di spazi in piu' o in meno...per questo che ho tenuto fartelo presente.

Ribadisco, non prendere i miei commenti come critiche distruttive, per quei pochissimi soldi non prettendo il mare lol :D Aiutando te aiuto me e aiuto anche eventuali altri noob che come me possono imbattersi in questi piccoli intoppi, tutto qui.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Ecco dove si va ad inserire dopo averlo spostato sopra la stringa che mi hai indicato nell'ultimo post (il che non cambia nulla di dove si trovava prima nella paginazione)

post-99-1273354767833_thumb.jpg

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

ma si si che prendo in modo costruttivo, mi sono spiegato male, me ne scuso. :D

postami tutto il codice da li in poi che me lo guardo, sinceramente non deve essere molto complicato.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Evvaiiii, ho risolto!! ^^

Allora la posizione dell'ads adesso e' questa:

post-99-12733564616685_thumb.jpg

Ti posto dove ho inserito il codice cosi' magari lo inserisci nel tuo file per coloro che hanno installato queste due mod come me :P

Dunque il tuo l'ho inserito subito dopo la stringa:

					<div id="thankers_{$post['post']['pid']}">{$post['post']['thankers']}</div>
</td>
</tr>
</tbody>
</table>
</div>
</if>
</if>
<!-- End [EN30] Ajax Thanks v1.0.2 -->

oppure subito prima della stringa:

[code] </foreach>
</if>
<!-- MOD LINKS -->
<if test="modOptions:|:$displayData['mod_links']">
<if test="showModOptions:|:$this->memberData['is_mod'] OR $this->memberData['member_id'] == $topic['starter_id']">

Insomma...in mezzo alle due :P

Grazie tante e scusa se ti ho trattenuto cosi' tardi!

Sono contentissima che funziona, per me e' vitale :D

Ti tartassero' di domande se ne avro' bisogno di aiuto in futuro ihihihi... :D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Avrei una piccola richiesta :P

Sarebbe possibile rendere lo spazio dell'ads uguale al post? Il titolo e' uguale ma il body no....mi piacerebbe se fosse possibile renderlo come un vero e proprio bot post. Cosi' sembra solo uno spazio vuoto sotto il primo post nel template, contenente l'ads.

Grazie mille in anticipo!! :D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Ehmmm....sono riuscita a fare questo:

post-99-12733649118372_thumb.jpg

Penso che mi basta cosi', l'ho reso uguale al box del thanks. Se trovi il modo di farlo uguale al post ne sarei comunque curiosa ma sono contenta anche di come sono riuscita ad impostarlo adesso.

Come vedi faccio le ore piccole quando qualcosa mi tormenta :D

Voglio mettere tutto online il prima possibile.

Non credo t'interessano le stringhe che ho aggiunto ma se le vuoi te le mando in pvt.

Ciaooo ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

scusa ma ieri sera sono andato a nanna, e stamattina internet non funzionava.

cosi direi che va bene, io gli avevo dato l'aspetto diciamo da renderlo attaccato al proimo post, ma volento si fa diventare come un post completamente separato.

adesso purtroppo ho parenti scassamaroni, ma spero più tardi di guardarmelo bene.

intanto grazie, ti metto di sicuro nei ringraziamenti nel primo post, aggiungendo il codice cha hai segnalato.

e poi provo a renderlo uguale identico ad un post.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Immaginavo fossi andato a dormire, infatti era tardissimo :D

Io ho dovuto continuare perche' il tempo stringe e voglio mettere il sito online al piu' presto.

A te l'aspetto di 'attaccato al primo post' funziona perche' lo sfondo base del tuo template e' bianco, pero' a me no, lo sfondo base a me e' blu, invece quello dei post e' azzurro chiaro quindi non sembrava affatto attaccato al primo post.

Comunque sono contenta di com'e adesso...non e' un post vero e proprio, nemmeno uno spazio vuoto. Ottimo direi ^^

Grazie per i ringraziamenti, se posso esserti utile non c'e che chiedere per quel poco che conosco di php lol :P

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

A te l'aspetto di 'attaccato al primo post' funziona perche' lo sfondo base del tuo template e' bianco, pero' a me no, lo sfondo base a me e' blu, invece quello dei post e' azzurro chiaro quindi non sembrava affatto attaccato al primo post.

Ho pensato un po.....

lo scopo è quello di farlo "sembrare" un nuovo post..... non di intergrarlo al primo. Oltretutto il thanks complica ulteriormente le cose, perchè come vedi stacca già l'aspetto....

possiamo vedere di personalizzare l'aspetto, ma ho bisogno (anche in privato) di tutto il codice topicviewtemplate e di uno screenshot un po più largo, per vedere cosa c'è sotto :D

Allacieca potrei dirti di cambiare questo:

<h3 class="header">Advertising</h3>

in

<h3>Advertising</h3>

oppure di toglierlo proprio

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada

Dunque cambiare

<h3 class="header">Advertising</h3>

mi toglie solo lo sfondo dal titolo e me lo rende di nuovo blu. Lascia stare, sono contenta di come e' adesso. Per me era importante avere l'adsense in pagina :D

Se riesco ad impostare anche l'altro ads nel post sarebbe stupendo; il max consentito da google e' di 3 per pagina quindi sarei apposto. Ora mi sono persa tra meta tags e varie impostazioni e plug in per il portale.....sono un pochetto stufa perche' vorrei caricare tutto sul sito e cominciare a postare :P

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PMI

Ciao,

mi aiutate ad impostare la cella dell'autore come le altre?

Le celle normali sono larghe 220px, mentre quella dell'autore adsense è larga 240px nonostante l'impostazione sia style="width: 220px;"

<td class='author_info' style="width: 220px;" >

<img src="http://www.invisionita.it/forum/public/style_images/master/adsense.png" WIDTH="140">

Inserisco qui una richiesta che riguarda questo script, se non è il posto giusto mi scuso in anticipo.

Questo script inserisce un adsense dopo il primo post. Sarebbe possibile modificarlo in modo tale che ne stampi uno dopo il primo post e uno dopo l'ultimo a patto che ci siano più di tre post?

Grazie mille.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

mi sa che c'è un errore nel punto e virgola finale

non cosi

<td class='author_info' style="width: 220px;" >

ma cosi

<td class='author_info' style="width: 220px"; >

Questo script inserisce un adsense dopo il primo post. Sarebbe possibile modificarlo in modo tale che ne stampi uno dopo il primo post e uno dopo l'ultimo a patto che ci siano più di tre post?

mmmmmh non so se so fare questa condizione.

perchè la cosa dei tre post?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PMI

Il primo l'ho risolto inserendo <td class='author_info' style="width: 210px">

mmmmmh non so se so fare questa condizione.

perchè la cosa dei tre post?

Ho detto tre post perchè penso che sia meglio che fra il primo e il secondo adsense ci siano almeno qualche post nel mezzo.

Ho provato a immaginarmi una discussione con un solo post, dove subito dopo compaiono due righe di adesense, e ho pensato che non fosse il massimo!!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

allora.

ti devo rimborsare la donazione.

mi sono accorto ora che la 3.1.2 ha la funzione integrata di inserimento del banner dopo il primo post (quindi questa mod non è piu necessaria). e in più (come desideri) puoi anche mettere un banner in fondo alle risposte.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

rimuovi il codice che hai messo, cosi togli la mod dal template.

ora vai nell acp -

1. Tools & Settings >

2. System Settings

Ad code integration

vai giu

Topic View

Code to display after first post

e se lo vuoi mettere anche in fondo a tutte le risposte, metti anche in

Override Footer Code

Ti ringrazio per non aver voluto il rimborso. Per quel che può valere come riconoscenza ti passo a Supporter

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
PMI

Grazie mille per la promozione!

Ho fatto come mi hai detto e funziona.

Fra l'altro ho recuperato la tabella che avevi fatto e l'ho incollata nelle textarea, in questo modo l'impostazione è più piacevole.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora

×