Vai al contenuto
najaru

3.x Risolvere il problema dei dell'upload dei video

Recommended Posts

najaru

Spesso si possono avere dei problemi di upload per i video di grosse dimensioni

Se il tempo scade il problema può essere che il file è superiore a post_max_size o a upload_max_filesize nel php.ini.

Il modo rapido per verificare è cercare di caricare un piccolo video, provare qualcosa di circa 500KB di 1 MB

Per quanto riguarda le dimensioni di upload (tenendo presente i limiti stabiliti nel php.ini) andare in ACP> My Apps> Gallery> Group Manager> (modificare un gruppo)> 'limite di upload media dimensione (in KB)? ' che è quella per i video .

Nella scheda successiva (il 'Spazio su disco / scheda Banda'), ci sono le impostazioni per le dimensioni di upload e spazio su disco max.

Una volta verificate impostazioni di gruppo, tornare alle impostazioni di Categoria (My Apps > Gallery > Categories), modificare una categoria. Sulla 'submission settings' tab, trovare e abilitare 'Allow multi-media submissions?'

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
onishima

Aggiungerei anche di controllare se hai l'estensione per quel tipo di video abilitata.

Perchè di formati video ce ne sono molti, io personalmente una volta avevo caricato wmv senza nessun problema.

Sarebbe interessante vedere quali altri formati è possibile inserire tra quelli non settati di default, e vedere cosa si riesce a caricare.

Modificato da onishima

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

Secondo me sono compatibili solo quelli elencati:

Quicktime Movie video/quicktime .mov

Windows Media Player video/x-ms-wmv .wmv

MPEG video/mpeg .mpg, .mpeg

AVI video/x-ms-asf .avi

Flash application/x-shockwave-flash .swf

avevo sentito qualcuno che aveva provato un altro tipo di file ma non andava.

Oltretutto non so neanche tutti i formati media che sono disponibili....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
AndrèsPapaleo

che plugin devo avere per vedere i file con estensione .wmv ?

Mi ha caricato solo la thumb del video, poi appare una scritta che dice " Missing Plugin"

Che devo fare ?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Alp_Vampire

Domanda: ip.gallery 4.0.3 è stato caricato un video con estensione .mp4, ma non mi viene visualizzato.. problema mio o di ipb? ho provato anche con altri browser oltre a safari, ma niente.. Inoltre come posso modificare l'elenco dei tipi di file da caricare?

Alessio

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Alp_Vampire

Allora.. sembrerebbe che i file .mp4 siano supportati.. se vai via ftp in admin/application_addon/ips/gallery/sources/classes/gallery/media.php alla linea 44 trovi:

	protected $_ext = array( 'flv' => 1, 'f4v' => 1, 'mp4' => 1, 'mov' => 1, 'm4a' => 1, 'm4v' => 1, '3gp' => 1, 'avi' => 0, 'wmv' => 0, 'mpg' => 1, 'mpeg' => 1, 'mkv' => 0 );

Ora provo a fare un'altra prova a vedere se riesco a risolvere.. vi terrò informati..

Alessio

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora

×