Vai al contenuto
dariada

Problema browser explorer

Recommended Posts

dariada    1
dariada

Dunque come il titolo stesso lo dice, ho un bel po' di problemini con il browser explorer.

Con Firefox non ho riscontrato alcun problema ne' di registrazione/log-in, ne di navigazione, ne di visualizzazione del sito in genere. Quindi i bug dell'explorer a cosa sono dovuti?

Io fino a prima di installare il forum avevo explorer 7. Quando ho cominciato riscontrare gli errori ho fatto l'upgrade dell'explorer pensando fosse dovuto ad un problema del mio pc. Siccome l'explorer 8 ha la mod compatibilita' si possono visualizzare anche gli errori riscontrati con le versioni datate.

Dunque questi errori sono: quando entro nel sito non mi fa il redirect, cioe' la pagina mi rimane bianca con su in alto solo il titolo del sito nella barra di navigazione. Perche' il sito carichi la pagina devo premere il pulsante aggiorna o F5 su tastiera. Secondo bug: una volta caricato il sito quando vado su Log-in lo clicco ma non mi fa di nuovo il redirect, rimango incchiodata silla pagina home; stessa cosa vale per Register. La cosa strana e' che ogni volta che la pagina si ricarica mi mostra sempre piu' utenti online, li moltiplica per il numero di volte che ci provo a fare il log-in/register!!

La pagina home su firefox si presenta cosi':

post-99-12736743493069_thumb.jpg

Invece la home con la funzione compatibilita' on, si presenta cosi':

post-99-12736745298878_thumb.jpg

Se voglio che mi funzioni per forza il forum in explorer, devo togliere la compatibilita', cliccare destra su un link e dal menu' a tendina scegliere apri in nuovo tab, e con questo mi si corregge il bug del redirect e mi permette il log-in e il register. Ma non posso mica scrivere in primo piano per tutti gli utenti che devono clicare destra, ecc ecc...oppure andare su firefox perche explorer non va, per di piu' tantissima gente usa ancora explorer 6-7....che faccio, quelli li mando via??

Help please!!! :(;);)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru    970
najaru

si vedo parecchi problemi.

ho provato addirittura con un IE6 e rimane tutto piantatissimo. Però sinceramente non ho mai riscontrato problemi di questo tipo su altri forum (piccoli errori nella visualizzazione del template si, ma i tuoi sono errori enormi)

dubito che sia la skin.

potrebbe esserci qualcosa di corrotto nei file ma non saprei dirti cosa.

Mi viene il dubbio però che il problema sia altrove. Se per caso tu hai un tuo dominio dedicato, ma sei hostata su un servizio gratuito tipo altervista, potrebbe esserci qualche problema nei redirect che non sono dipendenti dalla board.......perchè magari quei link vengono interpretati male dal browser.....e vengono aggiunti un sacco di numeri alla fine che invece non ci devono essere....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

si, sono su altervista, ma il dominio l'ho comprato sempre da altervista quindi ho fatto il cloack dello stesso...non dovrei avere problemi di redirect e se fossero problemi dovrebbero esserci anche su firefox o qualsiasi altro browser. Inoltre ho gia' chiesto ad altervista e mi dicono che non dipende da loro.

Mentre stavo aspettando una risposta sono andata su google e ho trovato questo topic:

http://community.invisionpower.com/topic/281981-ways-to-compensate-for-ipb-3-x-not-fully-supporting-ie6/page__st__80

e ci sei anche tu. Quindi il problema e' la compatibilita' della ipb con i vari skin e i vari browser. Percio' sono fregata perche' penso che la tizia che ha creato il mio non l'ha reso compatibile con explorer 6-7. Ho anche letto vari post nel suo forum dove parecchia gente chiede aiuto per errori del genere. E mo che faccio? Cambio skin?? ;);)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

dimmi quel

</if>

da dove l'hai tirato fuori? nel mio template non c'e...almeno non dopo quella stringa..

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru    970
najaru

togli l' if dalla riga che hai aggiunto. rivedi il tutorial, l'if nella riga aggiunta non ci deve essere

piano piano con te mi correggo tutte le cagate che ho scritto

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

infatti l'ho tolto, adesso lo skin si e' rimesso a posto. Ora devo sloggare e provare il log-in/register. Un'attimo....vediamo se questo corregge qualcosa...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

evvai...un piccolo passo avanti!! ;)

Ora riesco a fare il log-in sia in explorer 8 che in compatibility view cioe' explorer 6-7...e una e' andata!!

Ora rimangono la pagina bianca all'entrata, e quel cavolo di resize image invece dell'immagine in explorer 6-7.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru    970
najaru

ma.... io con ie6 non vedo il modulo per il login

non ti converrebbe sostituire radicalmente i link portal forum utenti con dei link fissi inseriti a mano?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

no...non ho cambiato nulla, lo skin e' esattamente come l'ha creato la tizia, io non ho manipolato nulla. Il redirect esiste solo il cloacking del nome del dominio liv 2 su quello liv 3 e non deve incidere, quello l'ho fatto prima di installare la board. No ho messo nessun FURL ne rewrite, ne creato cartella htaccess anche se e' abbastanza pericoloso lasciare cosi' senza protezione...qualsiasi hacker potrebbe crearmi dei danni....L'unica spiegazione la trovi nel sito della invision: ipb 3.x non e' stata creata per essere compatibile con explorer 6 e a malappena con 7, quindi le skin ne soffrono maggiormente perche' i creatori si sono concentrati nella creazione su altri browser senza bug. Ed io sono comunque fregata. ;)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

si lo so, ho letto in quel topic, ma io non voglio questo...la maggior parte della gente usa explorer 6 e 7 e non vogliono o non possono cambiare e io non voglio spaccarmi la testa a moddare due skin! questo e' un motivo; poi non mi pare nemmeno giusto che alcuni vedono il mio sito con un certo aspetto e altri no. E poi solo perche' ci sono piattaforme come vBulletin dove queste assurdita' non esistono, io non voglio lasciare cosi' questa cosa ;)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

uffa non mi va di spendere altri 300-400 euro per comprare la vBulletin -,-

Che si fa?? SIGH!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

sul sito ufficiale la vB 4 suite costa 190 euro...metti che devo comprare anche la skin, e qualche mod che magari non conosco visto che non ho mai avuto a che fare con la vB 4...dove arrivo? ho gia speso 1 sacco per la ipb ;)

Tu quale tipo di licenza hai? la forum o la suite?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
dariada    1
dariada

Sono riuscita a trovare una soluzione (spero temporranea....) per il bug dell'explorer; premendo CTRL + F5 si riesce ad effettuare il log-in/register. Mi rimane un'unico problema, quello del redirect quando clicco il il link FORUM dal portale...ma mi arrendo.

Ho eliminato gran parte dei mod che avevo installato, ho dato una ripulita alle cartelle chache e ho fatto rebuild; adesso avrei una richiesta da fare: mi potresti dire per favore che impostazioni ha fatto qui per nascondere i link nei post agli utenti non registrati? Ho provato varie impostazioni ma non sono riuscita ad indovinare quelle giuste.

Se riesco a impostare quello potrei finalmente muovermi avanti.

Grazie!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora


×