Vai al contenuto
Samul2

3.4 Trasferimento sito!!!!!!! aiuto...

Recommended Posts

Samul2

Allora ho dato via MP delle prove dell'autenticità della mia board agli admin.

 

--

 

Ora o bisogno del supporto è urgentissimo!
Ho trasferito il mio vecchio sito al nuovo dominio solo che non riesco a trasferire il database. Adesso, io sul mio pc ho una ad una tutte le tabelle utilizzate da ipb nel database del vecchio sito  in formato sia .sql che .sql.gz perché il vecchio database conteneva dati di più software e volevo mettere a parte quelle del forum.

Adesso, io ho installato ipboard da capo sul nuovo dominio poi ho svuotato il database, quindi ora ip.board non funziona.

Ora non so come caricare le tabelle del database sul sito! Ho accesso a cPanel e phpMyAdmin.

Vi prego aiutatemi non so veramente come fare!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Insomma non trovo veramente un modo di risolvere la faccenda sono disperato veramente stavolta... vi prego aiutatemi

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
fil17

Hai i files del vecchio forum?

 

Se li hai ancora ti basta caricare prima via ftp tutti quanti i files del vecchio forum, fatto questo via phpmyadmin importi il vecchio database nel nuovo hosting.

 

Se il database è troppo grande allora dovrai spezzettarlo in tante parti ed eseguire l'import in più fasi.. se invece il database è piccolo allora dovresti riuscire a fare tutto in un colpo solo.

 

Inoltre ricorda di modificare le configurazione del nuovo server, quindi la path di installazione. Modifica anche il file di configurazione con le nuove password del database e l'indirizzo del database (a volte è localhost.. a volte i provider assegnano un indirizzo loro)

 

Ciao!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Sì ma il problema è un altro.

Se io portavo i files già installati mi dava MySQL error.

Allora ho dovuto disinstallarla (vuotare il conf_global.php) e reinstallarla.

Poi ho cancellato tutte le tabelle del database rendendo anche quello vuoto.

Adesso, io non so come si fa ad importarle: se ad esempio carico (con l'opzione importa) il file "admin_login_logs.sql" mi dice "admin_login_logs table not exist" o qualcosa del genere e non me la fa caricare.

Allora, io temo che se carico il file "forum-db-backup.sql" (del admincp) o "localhost.sql" (del phpMyAdmin) mi dica "forum-db-backup.sql/localhost.sql table not exist"!

Allora io inizialmente avevo pensato di installare IP.Board in modo che le tabelle si creassero da sole e poi sovrascriverle una ad una caricando quelle che ho io, ma la maggior parte non me le caricava a mi dava messaggi d'errore incomprensibili.

Adesso veramente non so che fare... ma non sarà che i file li devo "eseguire" sull'opzione SQL anziché importarli?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

non sai trasferire un sito questo abbiamo capito. non servono gli "aiutateemmiii", e neanche 12 punti esclamativi,  è penoso ( ultimo avviso)

Spostare un sito significa spostare i files ed il database. Hai fatto un brodo ....

 

Se vuoi caricare il database non ci devi smanettare sopra, lo devi caricare e basta. Se contiene tabelle inutili le cancelli dopo.

Il conf_global.php va adattato. Quando hai installato ipboard da capo sul nuovo dominio , potevi salvarlo per vedere le stringhe di configurazione ed aggiustare il vecchio conf_global.php

 

Reinstallare la board vergine non serve a niente, se non per vedere come si riempie correttamente il conf_global.php

 

PUNTO.

 

p.s. hai un hosting decente ?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2
p.s. hai un hosting decente ?

http://netsons.com ---> hosting professionale condiviso.

 

Adesso tu mi hai detto tutto e mi hai detto niente.

Con la board installata da capo così, ho speranze o no? Se sì, potresti per favore dirmi passo passo che fare, visto che con SQL io sono ufficialmente negato?

Modificato da Samul2

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Ok ho caricato tutto il vecchio db su quello nuovo. Risultato?

 

 

Errore

Query SQL:

--
-- Database: `my_pokemonglobal`
--
CREATE DATABASE `my_pokemonglobal` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci;
 

Messaggio di MySQL: dot.gif

#1044 - Access denied for user 'espsohid'@'srv-hp10.netsons.net' to database 'my_pokemonglobal'
Modificato da Samul2

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

i motivi per cui non si riesce ad importare un database sono molteplici

comunque un hosting professionale da 10 Euro l'anno (questo ? http://www.netsons.com/hosting.php) non ti permette di lavorare con serenità

 

anche se avessi tutto l'accesso al tuo pannello ed a tutti i tuoi dati  non saprei come aiutarti

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
fil17

Come detto da gianpiero è dura capire i motivi per la quale il database non viene importato.

 

Prova ad eliminare tutti i database che hai creato su netsons.. fatto questo crea un nuovo database con lo stesso nome, lo stesso username e la stessa password di quello vecchio.


Fatto questo collegati via phpmyadmin al database ed esegui l'import.


Se anche così non funziona allora ti consiglio di chiedere supporto a netsons.

Modificato da fil17

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2
Come detto da gianpiero è dura capire i motivi per la quale il database non viene importato.

 

Prova ad eliminare tutti i database che hai creato su netsons.. fatto questo crea un nuovo database con lo stesso nome, lo stesso username e la stessa password di quello vecchio.

Fatto questo collegati via phpmyadmin al database ed esegui l'import.

Se anche così non funziona allora ti consiglio di chiedere supporto a netsons.

adesso sto provando ad importare il file localhost.sql.zip, vi faccio sapere.

 

 

lasciatelo perdere, è un utente che abbiamo già allontanato più volte

per favore permettimi di ricevere supporto almeno stavolta, è questione di vita o di morte

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

allora io ho importato correttamente il file (ho dovuto modificare pokemonglobal.altervista.org e sostituirlo con pokemonglobal.it con il comando "trova e sostituisci". ho fatto la stessa cosa con my_pokemonglobal che ho rinominato col nuovo db: espsohid_forum, e ho cancellato il comando "create database"), e le tabelle sono state create. però il forum continua a funzionare. il messaggio che ricevo è: 

 

FATAL ERROR
Your settings could not be read by IP.Board. This is a fatal error and IP.Board cannot function while this issue persists.

This issue is generally caused by changing your character set in the ACP to one that does not support data stored in the rest of your settings, or by restoring a database backup/completing a server transfer and importing your database tables using the wrong character set or collation.

che devo fare?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Uhm prima di provare espongo il problema.

Mi sono accorto che se installo così di suo il database ipb funziona.

Se carico le tabelle su un altro database, e dal conf_global.php camio il database in uso, non funziona.

Questo è tutto.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

Mi sembra di parlare con un Troll, anzi, se fosse un troll sarebbe più facile. fai un giro della sedia e rileggi quello che hai scritto dimmi cosa hai capito

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

uhm cosa c'è da capire? un database me lo prende, quell'altro no. punto.



anzi facciamo una cosa: ricominciamo da capo.

sul vecchio sito ho ancora ipb installato: posso comunque ricopiarlo sul nuovo sito. ora trasferisco di nuovo tutto. quando ho finito ve lo dico

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

ok ora devo esportare il database ed importarlo.

mi dice che non ho accesso al db my_pokemonglobal con l'utente espsohid_forum. è evidente dunque che così com'è il backup non va bene. ora vi dico tutte le opzioni che posso spuntare quando lo ESPORTO e ditemi quali devo spuntare per favore.

 

-disabilita i controlli sulle chiavi straniere

-aggiungi drop database

-aggiungi drop table/view/procedure/function

-aggiungi if not exist

-aggiungi valore auto_increment

-usa i backquotes con i nomi delle tabelle e dei campi

-aggiungi create procedure function

-creazione/aggiornamento/controllo date

-inserimenti completi

-inserimenti estesi

-utilizza inserimenti ritardati

-utilizza gli ignore inserts

-usa dati esadecimali per blob.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

Hai creato gli opportuni utenti con password per poter accedere al database? I privilegi dell'utente non danno il permesso di accedervi ... questo dice l'errore.. altrimenti come dice gianpiero devi riconfigurare il config_global.php

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

allora.

adesso conf_global.php non credo che c'entri, perché prima di collegarlo al db devo prima metterci le tabelle al db no?

allora, il database my_pokemonglobal e il db del mio sito sono su due host diversi (uno è su pokemonglobal.altervista.org ed è localhost e l'altro è su mysql.netsons.com) e non so come far sì che il mio utente possa accedere all'altro database!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Askancy

Apri un ticket su IPS, lo staff di IPB ti aiuterà con il trasferimento gratuitamente.

Per aprire un ticket devi avere una licenza ed accedere nel Client Area.

Tanto si è capito si è capito che non sai a cosa serve il config_global, cosa sono è l'sql ne cosa è localhost, quindi è inutile continuare quando ci sono centinaia di topic già affrontati per il trasferimento di una board da host a host.

 

Apri un ticket su IPS.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Ho aperto il ticket e mi hanno aiutato in tempo record!

Ok, ho risolto! Grazie comunque a tutti quelli che mi hanno aiutato!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

Potresti gentilmente riportare come hai risolto? volevo aiutarti io ma è abbastanza complesso l'argomento... ho trovato questa guida di bfarber che potrebbe servire anche ad altri ma non sono sicuro che sia una soluzione al tuo problema samul.

Aspetto tue notizie ;)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Samul2

Dunque, la guida non ho trovato il tempo di leggerla.

Comunque, dopo aver aperto il ticket, ho fornito le credenziali di accesso al phpMyAdmin di AlterVista e a quello di NetSons.

La IPS in poco tempo mi ha trasferito il tutto, e quando ho chiesto loro come avessero fatto, dalla spiegazione ho capito che io sbagliavo perché esportavo l'intera "struttura" del database, mentre invece dovevo esportare solo le tabelle.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Ospite
Questa discussione è chiusa.

×