Vai al contenuto
Barrnet

Problema con il di conferma email e recupero password

Recommended Posts

Barrnet

Salve,

Da alcuni giorni il forum che gestisco con IPB 3.3.4 ha alcuni problemi con le email di recupero password e di conferma email: ovvero non funzionano e all'utente viene restituita la pagina di errore 404.

I link sono del tipo: http://minecraftitalia.net/forum/index.php?app=core&module=global%C2%A7ion=register&do=0X

Dove l'X finale è omesso per evitare che tale url sia attivo.

Avete idee di come risolvere o di come individuare quale sia la causa del problema?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero
Da alcuni giorni il forum che gestisco con IPB 3.3.4 ha alcuni problemi con le email di recupero password e di conferma email:

 

ovviamente "per caso" cioè nessuno ha fatto modifiche alla skin alla lingua etc.etc....

 

Io propongo un bel upgrade alla 3.4.3

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Barrnet

ovviamente "per caso" cioè nessuno ha fatto modifiche alla skin alla lingua etc.etc....

 

Io propongo un bel upgrade alla 3.4.3

 

La lingua non è mai stata modificata da un anno a questa parte, non è altro che una traduzione dell'interfaccia utente homemade.

di questo problema ci siamo accorti qualche giorno fa, le uniche modifiche sono state una disattivazione degli hook non vitali per migliorare le prestazioni del forum, in quanto siamo un pò stretti di cpu dedicata e il forum era diventato una lumaca, con la cpu sempre fissa a 100%.

Tale problema sembra indipendente dallo stile, anche perché ha poco senso: non è mica lo stile a generare dinamicamente l'url per attivare un account.

io consiglierei di ricaricare tutti file originali della board via ftp

Si perderanno eventuali hook installati?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

ricaricare files originali è come ammettere che sono state fatte modifiche a quelli che ora sono on line

A me non è mai successo che i files si modificassero da soli. Il consiglio di najaru ha senso : tagliamo la testa al toro che spesso conviene e si perde meno tempo.

 

Non puoi avere risultati inattesi se ricarichi i files originali DELLA STESSA VERSIONE CHE HAI ON LINE.

 

P.S. Mi sono registrato al tuo forum , utilizzando la lingua inglese e skin originale IPB. Ho fatto il recovery della password senza problemi

 

Constato inoltre che il link che hai postato ad inizio discussione è:

 

 

http://minecraftitalia.net/forum/index.php?app=core&module=global§ion=register&do=0X 

 

mentre dovrebbe essere

 

 

http://minecraftitalia.net/forum/index.php?app=core&module=global&section=register&do=0X 

 

post-550-0-13635000-1365197545_thumb.jpg

 

 

c'è un problema di codifica caratteri o altre diavolerie che potrebbe non dipendere dal forum ma dai browser o clients di posta usati

 

cioè la global&section  diventa global§ion

 

 

Non so dove andare a parare per questo ... fenomeno. Non mi è nuovo l'ho già visto :wacko:

 

Un'occhiata qui :

 

http://community.invisionpower.com/topic/382315-strange-character-in-url-moderateion/#entry2384915

 

 

 

 

Modificato da gianpiero

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

in

Settings: Email Set-up

 

imposta

 

Send HTML emails No

 

 

Modificato da gianpiero

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
najaru

gianpiero sei veramente mitico. quando io dico di ricaricare tutti i file lo faccio anche perchè non si sa cosa abbiano pasticciato/combinato gli utenti con i propri file, cartelle di prodotti terzi caricati nel percorso sbagliato, software diciamo che arrivano da siti non proprio autorizzati eccetera. Ricaricarli (DELLA STESSA VERSIONE DI BOARD OVVIAMENTE) male non fa e non c'è nessun rischio per le skin, hook e lingue. Partono solo alcune immagini, ma faccio una mini guida per questo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

diciamo pure che tenere i files vergini senza modifiche manuali è raccomandabile. :)

 

Tornando alla mia analisi di prima confermo che Thunderbird ( il mio client di posta) trasforma &sec in §.
Però cliccandoci sopra l'indirizzo viene restituito giusto e si apre la pagina giusta. Questo il motivo per cui non ho avuto problemi a fare il recovery della password.

 

Quindi la soluzione di fare le email in TEXT piuttosto che HTML risolverà il problema solo se a monte (dal forum) parte l'indirizzo giusto. Credo che convenga provare.

 

Io faccio sempre le comunicazioni in TEXT per avere massima compatibilità, l'opzione di scelta esiste proprio per questo motivo.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Barrnet

Al forum on vi è alcuna modifica salvo l'installazione di qualche hook, però questo problema si è presentato pure in performance mode. A questo punto credo che effettivamente il problema dipenda dalla traduzione italiana da noi fatta artigianalmente.

Il ripristino ftp lo consiglio pure io sul forum di supporto ad un'altra piattaforma (phpBB3) ma non ero certo se il fare un ripristino ftp comportasse la perdita delle configurazioni degli hook o gli stessi erano salvati nel database.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

A questo punto credo che effettivamente il problema dipenda dalla traduzione italiana da noi fatta artigianalmente.

 

 

 

Sul mio forum se faccio recovery della passw con la board in lingua inglese mi arriva la mail  in inglese, se lo faccio in italiano mi arriva la mail in italiano.

Sul tuo forum no.

 

Il recovery della password sul mio forum non trasforma i caratteri tanto da rendere inagibili i link, sul tuo si

 

&sec che si trasforma in § è un problema che va al di la della lingua

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Barrnet

La mail arriva in inglese perché la traduzione da noi fatta non è completa.

Abbiamo duplicato la lingua inglese e abbiamo tradotto il più possibile dell'interfaccia utente, tant'è che il panello amministrativo è ancora in inglese.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

Sul mio forum se faccio recovery della passw con la board in lingua inglese mi arriva la mail  in inglese, se lo faccio in italiano mi arriva la mail in italiano.

Sul tuo forum no.

 

Sul tuo forum non arriva la mail in inglese, mai

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

al di là dell'osservazione di najaru , ritengo che la lingua inglese così come la skin originale, non si dovrebbero mai toccare perchè sono le uniche di "riferimento"

Prima di intervenire sulla lingua italiana per trovar soluzione al problema del thread, io rifarei la costruzione della lingua inglese tramite query.

 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
gianpiero

qui l'autore del thread si è eclisssato, comunque mettendo le mail in TXT mi pare abbia temporaneamente risolto il problema iniziale -_-

Modificato da gianpiero

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora


×