Vai al contenuto
Daniele81

3.4 Problema dopo conversione

Recommended Posts

Daniele81

Ho fatto una conversione da Phpbb a IPS in questi giorni, tutto ok a parte per strane cose...

 

Se attivo il Redirect to new friendly URL format con Htaccess per le url del vecchio forum per il redirect301 le patch vanno a farsi benedire... Forse devo cambiare il tipo di url deselezionale Query String?

 

Poi da quando ho cambiarto cartella, perché prima era su una cartella dedicata non mi caricano più i banner Adsense.

 

Qualcuno mi aiuta? Please!

Ci sto sbattendo la testa senza trovare una soluzione...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniele81

Adesso ho notato che se metti "?" dopo index.php si vedono  O_O

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

bisogna configurare opportunamente i link con lo script che trovi in app_converters_1213.zip\app_converters_1213\Tools\Links - phpBB all'interno troverai 4 file che andrebbero sovrascritti o aggiunti agli esistenti.

config.phpmemberlist.phpviewforum.phpviewtopic.php

non ricordo i passaggi successivi, ma nel forum c'era una discussione a riguardo.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniele81

Al momento la cosa del redirect l'ho sistemata lato Server disabilitando l'htaccess di IPS che mi dava un po' di problemi lato path relativo.

 

L'unica cosa che non comprendo il perché dopo che ho cambiato cartella e attivo l'htaccess della board mi ha sballato la visualizzazione dei banner adsense. Ora su index.php non si vedono e invece su index.php?ciccio si vedono invece, anche se l'htaccess è disabilitato... Boh

Modificato da Daniele81

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniele81

Forse sono ad una svolta.

Può essere che mi crea questo conflitto perché la mia cartella del forum si chiama public e all'interno di IPS c'è già una cartella public?

Stranamente cambiando nome funziona...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Askancy

Forse sono ad una svolta.

Può essere che mi crea questo conflitto perché la mia cartella del forum si chiama public e all'interno di IPS c'è già una cartella public?

Stranamente cambiando nome funziona...

Può essere che l'htaccess "confonda" le cartelle, ma non sò dirti con certezza se è questo il motivo... Ma perché la chiami public e non semplicemente forum?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniele81

l'htaccess avevo provato anche a toglierlo e quindi non averlo, ma idem.

L'ho chiamata public perché nella vecchia board avevo quella cartella e volevo avere lo stesso link di sempre.

Ho provato a contattare anche il servizio di assistenza Invision, ma non mi hanno dato molte informazioni aggiuntive.

Credo che dovrò cambiare il nome alla cartella e fare un redirect verso quella per quelli che vanno su public :(

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniele81

Piccolo aggiornamento:

Dall'assistenza Invision mi hanno confermato che potrebbe essere un bug, ma al momento non si mettono a correggere bug della versione 3.

Ho cambiato nome alla cartella XD

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Askancy

Piccolo aggiornamento:

Dall'assistenza Invision mi hanno confermato che potrebbe essere un bug, ma al momento non si mettono a correggere bug della versione 3.

Ho cambiato nome alla cartella XD

perfetto, casomai per evitare la perdita di utenti metti un redirect dalla cartella public

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora

×