Vai al contenuto
mr-unix

3.4 database dopo cambio server

Recommended Posts

mr-unix

ciao a tutti,

ho un grave problema sopo una migrazione del server mi appare questo messaggio del database:

 

Your settings could not be read by IP.Board. This is a fatal error and IP.Board cannot function while this issue persists.

This issue is generally caused by changing your character set in the ACP to one that does not support data stored in the rest of your settings, or by restoring a database backup/completing a server transfer and importing your database tables using the wrong character set or collation. You should contact IPS Technical Support for further assistance.

 

 

grazie a chi mi risponde!!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
mr-unix

è stata solo una migrazione del pannello, ora il sito per 1 mese è ancora visibile sul vecchio server, ma su quello nuovo esce l'errore descritto, si ho messo i dati nuovi in conf_global.php.....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Agnello

Se hai fatto backup del database, e sei sicuro che sia stato fatto bene, non perderai niente. Stai tranquillo.

Purtroppo non mi sento di aiutarti perché non sono ferratissimo ma controllerei, appunto,il character set. In phpmyadmin dovresti avere un'indicazione del character set utilizzato, e questo dovrebbe corrispondere con quello che utilizzavi prima nella board. 

Forse sei nella mia stessa situazione, ovvero board nata molti anni fa con character set iso-8859-1 e portata avanti senza conversioni. Ora il character set di default in invision è UTF-8 e forse per questo ti da problemi. Controlla queste cose così chi è più esperto di me capirà prima dove sta il problema.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
mr-unix

infatti io ho iso-8859-1 nel forum, se metto UTF-8  sul forum appaiono dei simboli strani, nel database ho questo valore:

collation uf8mb4_unicode_ci   dal menu a tendina posso cambiarlo credo e metterci iso-8859-1 ?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Agnello

Prova, tanto hai il backup. Sempre che tu ce l'abbia! 

Altrimenti fai backup.

Modificato da Agnello

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniel

Ciao, usi uno shared o vps/dedicato? se ne hai la possibilità di accedere alla macchina ti consiglio di fare il backup con il tool da riga di comando mysqldump

altrimenti puoi usare questo tool molto semplice che backuppa il database usando la funziona system() dal php

basta che crei un file .php e lo visiti dal browser. alla fine ti ridarà nella stessa cartella il file in sql.gz

<?php
system("mysqldump --host=localhost --user=USER --password=PASSWORD DB_NAME | gzip > backup.sql.gz");
echo "Compressione del file.....";
echo "Terminato. Potete recuperare il database tramite FTP";
?> 

chiaramente devi modificare i dati USER, PASSWORD E DB_NAME in base al tuo conf_global.php

il metodo più indicato nel tuo caso (anche per il restore) è un altro.è il tool mysqldumper http://sourceforge.net/projects/mysqldumper/files/MySQLDumper/MySQLDumper1.24.4.zip/download

lo scompatti. carichi nella home del tuo sito. tramite browser configuri lo script con user/password associati al tuo db. ti crei il backup e sei apposto. scarichi il backup. installi lo stesso tool sul nuovo host caricando il backup nella cartella "work" (se non ricordo male)

a questo punto ripristini il DB e non dovresti avere nemmeno problemi di accentate o di altro tipo....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
pingoso

Ciao a tutti, dopo anni torno da queste parti, purtroppo a causa di un problema.

Da qualche ora ottengo lo stesso messaggio che ha indicato mr-unix all'inizio del topic, seppur io non stia praticando alcuna migrazione o altro.

L'unica cosa che posso supporre è che sia stato modificato qualche cosa da parte del provider che però, probabilmente, non mi darà risposta sino a domani mattina.

Senza poter accedere al pannello amministrativo, non ho modo di modificare questo parametro in maniera reversibile da qualche parte?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
pingoso

Uhm, work-around trovato, ma...

Nel file conf-global.php ho impostato la variabile $INFO['sql_charset'] a 'latin1', ma il mio DB è in utf8_unicode_ci ...

...possibile impostazione del virtual host?

 

EDIT: Che strana cosa...

Quote
character_set_client latin1
character_set_connection latin1
character_set_database utf8
character_set_filesystem binary
character_set_results latin1
character_set_server utf8
character_set_system utf8
character_sets_dir /usr/local/share/mysql/charsets/
collation_connection latin1_swedish_ci
collation_database utf8_unicode_ci
collation_server utf8_unicode_ci

 

Modificato da pingoso

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
pingoso
Quote

The problem is, that PHP 5.4 used "latin1" as default-charset. PHP 5.6 now uses "UTF8" as charset.

Penso possa aiutare in futuro :)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
mr-unix

ciao e grazie per il tuo aiuto, lo script che mi hai postato non mi fà nessun  backup,io sul vecchio server ho i backup giornalieri che si creano in automatico, il problmea é nato da quando ho spostato il forum su di un nuovo server che da problemi con dei caratteri credo...

per ora ho un mese di tempo perchè quello vecchio di server lo lasciano attivo fino a quando non si risolve.....

Modificato da mr-unix

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Agnello

Fatti cambiare la versione php dal nuovo provider, fatti mettere php 5.4. Come ha detto Pingoso il problema può essere quello.

 

Modificato da Agnello

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
mr-unix
On 10/2/2016 at 7:13 PM, pingoso said:

Uhm, work-around trovato, ma...

Nel file conf-global.php ho impostato la variabile $INFO['sql_charset'] a 'latin1', ma il mio DB è in utf8_unicode_ci ...

...possibile impostazione del virtual host?

 

EDIT: Che strana cosa...

 

mancava questo! $INFO['sql_charset'] a 'latin1' adesso funziona,,,,,,!!!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniel
21 hours ago, mr-unix said:

ciao e grazie per il tuo aiuto, lo script che mi hai postato non mi fà nessun  backup,io sul vecchio server ho i backup giornalieri che si creano in automatico, il problmea é nato da quando ho spostato il forum su di un nuovo server che da problemi con dei caratteri credo...

per ora ho un mese di tempo perchè quello vecchio di server lo lasciano attivo fino a quando non si risolve.....

probabilmente hai le variabili system() e shell_exec() bloccato dal tuo host.

che pannello è? plesk? cpanel? directadmin? l'hosting è condiviso o un vps/dedicato?

se hai accesso ssh sul tuo vecchio server e anche sul nuovo ti consiglio di usare l'utility da console mysqldump

 

On 10/2/2016 at 7:13 PM, pingoso said:

Uhm, work-around trovato, ma...

Nel file conf-global.php ho impostato la variabile $INFO['sql_charset'] a 'latin1', ma il mio DB è in utf8_unicode_ci ...

...possibile impostazione del virtual host?

 

EDIT: Che strana cosa...

 

sicuro che l'host (presumo shared) non abbia fatto qualche modifica sulla versione del mysql o php?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
pingoso

Certo, il provider sta procedendo da alcuni mesi alla migrazione di PHP.

La versione 5.4 ha raggiunto l'end of life, quindi tornare indietro non penso sia la soluzione!
Io ora mi sono spostato sulla versione 5.6 ed ho specificato manualmente il charset da utilizzare all'interno del file conf-global.php risolvendo i miei problemi.

Probabilmente sarà necessario preventivare una migrazione della banca dati.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Daniel
4 hours ago, pingoso said:

Certo, il provider sta procedendo da alcuni mesi alla migrazione di PHP.

La versione 5.4 ha raggiunto l'end of life, quindi tornare indietro non penso sia la soluzione!
Io ora mi sono spostato sulla versione 5.6 ed ho specificato manualmente il charset da utilizzare all'interno del file conf-global.php risolvendo i miei problemi.

Probabilmente sarà necessario preventivare una migrazione della banca dati.

effettivamente è vero. la 5.6 è l'ultima versione utile da poter usare con la 3.4.x

PHP 7 purtroppo non è compatibile con la 3.4.x, invece ha piena compatibilità con la 4.1.x

infatti ho upgradato il server alla 7.0.0 in questi minuti. :)

dimmi una cosa, nel pda system setting--> Server Environment--> Document character set, che codifica hai?

Da quello cho ho potuto vedere Agnello ha ragione. con le vecchie board la codifica di default è "ISO-8859-1" invece nella board più recenti la codifica è "UTF-8"

anche se alla peggio si dovrebbe risolversi usando questa procedura da query sql, specificando i giusti campi. (assolutamente da fare non su una board live, se non si è sicuri..)

update <table> set <field> = replace(<field>, "ë", "ë")
update <table> set <field> = replace(<field>, "Ã", "à")
update <table> set <field> = replace(<field>, "ì", "ì")
update <table> set <field> = replace(<field>, "ù", "ù")

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

mr-unix

Quote

adesso mi trovo con un'altra gatta da pelare....

our profile photo directory is not writable
Please check the permissions on the profile photo directory '/home/www/8bb30f2576517a0aa433b064c6fbd005/web/uploads/profile/' and make sure that it is writable.
non posso scaricare e mettere allegati ho controllato è tutto su 777

Daniel

Quote

System setting---->general configuration--->Path to 'upload' directory--> nella descrizione c'e il nuovo "path"

inserisci quello :-)

P.s hai risolto con gli accenti?

mr-unix

Quote

si risolto l'unica cosa che non va sono gli avatar non li fa mettere...

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora

×