Vai al contenuto
iarno

Problema Conteggio visite

Recommended Posts

iarno

Salve a tutti, ho un problema sul mio forum da tempo ormai, in pratica da quando ho fatto il passaggio tra la versione 3.x.x. e alla nuova 4.x.x. il conteggio delle visite dei nuovi post rimane sempre a 0. Nella home principale il conteggio dei messaggi funziona, ma se entro dento la sezione e guardo i post, riportano sempre 0 visite.

Sapete percaso dove posso sbattere ulteriormente la testa per venirne a capo?

Modificato da iarno

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

bisogna controllare che la tabella "core_view_updates" non sia danneggiata

i conteggi vengono archiviati in quella tabella e aggiornati tramite una task nelle varie tabelle (contenuti). Bisogna quindi controllare il funzionamento della task.

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
iarno

Grazie mille per la risposta e scusami se ci ho messo tanto a risponderti ma non ho potuto farlo prima purtroppo.

Allora io ho controllato i task e mi sono accorto che praticamente non mi funzionano in automatico, li devo fare manualmente. Lanciato la task "viewupdate" ripristina tutte le visite in tutti i thread.

In effetti nella pagina principale me lo dice pure " Routine maintenance tasks are performed as users access the site but it looks like the traffic to your community is not sufficient to run these tasks on time. It is recommended that you set up a cron or a web service to ensure a backlog is not created. If you have recently switched to the 'Run Automatically with Traffic' it may take a short while for the backlog to be cleared and you can ignore this message. "

Ho capito che bisogna settare il metodo con qui eseguire le task, ma non so come si fa, attualmente è settato su " Run Automatically with Traffic (Default) " che evidentemente non va bene penso.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
BomAle

Al termine dell'upgrade io consiglio di avviare manualmente le task cosi da ricostruire i contenuti, indici di ricerca, e nel tuo caso anche quella delle visite... perchè potresti avere problemi (tanti contenuti, prioritá o errori) con altre task e non potendo andare avanti non riusciresti a far avviare quella task.

Ti consiglio di controllare i log della task viewupdates andando nell'AdminCP e andare nel modulo: app=core&module=settings&controller=advanced&do=tasks e digita "viewupdates"... da li puoi monitorare gli errori e in caso avviare manualmente e seguire il processo.

Screenshot_2016-10-24-00-52-36.png

Una volta terminato dovresti ripetere manualmente l'avvio per le altre task, fino a quando non smaltisci le task associate al "rebuild". Il metodo utilizzato in base al traffico dovrebbe bastare ma solo dopo questo intervento.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
iarno

Non ho nessun log della task viewupdates ed il problema non è solo di quella task ma di tutte che non vogliono saperne di partire in automatico.

Ho provato manualmente a lanciare tutte le task, e riselezionato e salvato il metodo in base al traffico (anche se era già selezionato) ma non vanno ancora in automatico ridandomi sempre lo stesso messaggio:

 

Cita

 

Attività blocate

Routine maintenance tasks are performed as users access the site but it looks like the traffic to your community is not sufficient to run these tasks on time. It is recommended that you set up a cron or a web service to ensure a backlog is not created. If you have recently switched to the 'Run Automatically with Traffic' it may take a short while for the backlog to be cleared and you can ignore this message.

 

 
Intanto ti ringrazio, poi proverò ad aspettare il prossimo aggiornamento e rifare questa procedura.
Modificato da iarno

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
iarno

Non sono sparito.....Scrivo per dirti che dopo l'ultimo aggiornamento ho fatto come da te descritto, ho aggiornato tutte le task manualmente e poi ho aggiornato all'ultima versione il forum e adesso finalmente molte tak tra cui "viewupdates"  adesso funzionano.

Ti ringrazio per il tempo speso nell'aiutarmi, sei stato di grande aiuto. :ok:

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Ospite
Questa discussione è chiusa.

×